current position:Home>Upgrade glibc to 2.18 on Linux (CentOS)

Upgrade glibc to 2.18 on Linux (CentOS)

2022-01-26 23:45:42 youzjuer

Refer to the following documents :

error version `GLIBC_2.18' not found_Lloyd-He-CSDN Blog _glibc2.18icon-default.png?t=LA92https://blog.csdn.net/qq_39295044/article/details/86685789

The specific operation is :

Be careful : Better be in root User down operation , Otherwise, you may face the error that the file is not allowed to access , If you face this problem , After unsuccessful installation , Probably su The command cannot be used , At this point, you can refer to another article of mine , solve su The problem that the command cannot be used


1、 Download the file
Download address :https://mirrors.tuna.tsinghua.edu.cn/gnu/glibc/glibc-2.18.tar.gz

2、 Installation and deployment
decompression
tar -zxvf  glibc-2.18.tar.gz

Create build directory
cd glibc-2.18
mkdir build

compile 、 install
cd build/
../configure --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin

make -j 8
make install


### System version
7.8.2003  

copyright notice
author[youzjuer],Please bring the original link to reprint, thank you.
https://en.cdmana.com/2022/01/202201262345410358.html

Random recommended